
Transmit File Transfer Cheatsheet
A quick reference guide for Panic's Transmit, covering essential keyboard shortcuts, file operations, browsing, sync features, and useful tips for

efficient file transfer workflows.

Basics & Navigation

Common Shortcuts

Connecting & Disconnecting

Add New Server Click the ‘+’ button in the

toolbar or File > New Server

Connect to Server Select server from Favorites

list and press Enter, or use

File > Connect to Server

Disconnect from

Server

File > Disconnect

Edit Server

Favorite

Select favorite, press Cmd + 

E  or right-click > Edit

Duplicate Server

Favorite

Select favorite, press Cmd + 

D  or right-click > Duplicate

Delete Server

Favorite

Select favorite, press Cmd + 

Delete  or right-click >

Delete

Quick Connect

(Go to URL)

Cmd + K

Switch between

server

connections

Cmd + [  / Cmd + ]

File Browsing & Navigation

Go up one directory

(Local/Remote)

Cmd + Up 

Arrow

Go to Home directory

(Local/Remote)

Shift + Cmd 

+ H

Go to Root directory

(Local/Remote)

Shift + Cmd 

+ R

Go to Path… Shift + Cmd 

+ G

Refresh directory listing Cmd + R

Show hidden files Cmd + Shift 

+ .

Show/Hide sidebar Cmd + 0

Show/Hide transfers window Cmd + T

Focus Local pane Cmd + Option 

+ L

Focus Remote pane Cmd + Option 

+ R

Basic File Operations

Upload selected

items

Select items in Local pane,

press Cmd + Up Arrow

(towards remote)

Download selected

items

Select items in Remote

pane, press Cmd + Down 

Arrow  (towards local)

Copy selected

items

Cmd + C

Paste copied items Cmd + V  (pastes into

current directory of active

pane)

Rename selected

item

Press Enter  or Return

Delete selected

items

Press Delete  or Cmd + 

Delete

New Folder Shift + Cmd + N

New File Cmd + N  (creates in

active pane)

Edit selected file

(Local/Remote)

Select file, press Cmd + 

E  or double-click (uses

default editor)

General Shortcuts

Cmd + W Close current window

Cmd + Q Quit Transmit

Cmd + , Open Preferences

Cmd + ? Open Transmit Help

Spacebar Quick Look selected item

Cmd + Option + 1 View as Icons

Cmd + Option + 2 View as List

Cmd + Option + 3 View as Columns

Cmd + F Search in current directory

Transfer Shortcuts

Cmd + L Limit Transfer Speed (toggle)

Cmd + T Show/Hide Transfers window

Pause all transfers Cmd + Option + P

Resume all transfers Cmd + Option + R

Cancel selected transfer Select in Transfers window, press Cmd + 

Delete

Retry selected transfer Select in Transfers window, press Cmd + R

Clear completed

transfers

Cmd + K  in Transfers window

Transfer via Droplet Drag files/folders onto a Droplet icon

View Transfer Log Window > Show Transfer Log
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Advanced Features

Editing & Selection Shortcuts

Cmd + A Select All

Shift + Click Select a range of items

Cmd + Click Add/Remove individual item from

selection

Cmd + E Edit selected file (opens in external editor)

Rename item Enter  or Return

Apply changes to file/folder

permissions

Cmd + I  (Get Info), then make changes

Make Alias (Local files) Cmd + L  (macOS Finder shortcut, works

in Local pane)

Show original (Local files) Cmd + R  (macOS Finder shortcut, works

in Local pane)

Copy Path Right-click item > Copy Path

View & Window Shortcuts

Cmd + 1 Show Favorites

Cmd + 2 Show History

Cmd + 3 Show Panic Sync

Cmd + 4 Show Devices (Local)

Cmd + 0 Show/Hide Sidebar

Cmd + T Show/Hide Transfers Window

Cmd + Shift + L Show/Hide Location Bar

Cmd + Option + L Focus Local Pane

Cmd + Option + R Focus Remote Pane

Sync

Mirroring: Automatically synchronize changes

between local and remote folders.

Select local and remote folders.

Click the Mirror  button in the toolbar.

Configure direction (Local to Remote,

Remote to Local, Both).

Configure options (Newer items only, Delete

original items, Skip hidden, etc.).

Click Sync .

Note: Be extremely cautious with Mirroring,

especially with ‘Delete original items’. Always

review changes before proceeding.

Comparison: Compare local and remote folders

without syncing.

Select local and remote folders.

Click the Compare  button in the toolbar.

Transmit will highlight differences (Newer,

Older, Different Size, Missing).

Use this to manually identify items for

transfer or deletion.

Sync Rules: Define rules to include or exclude

specific files/folders during Mirroring.

Go to Transmit > Preferences > Sync Rules.

Add rules based on file name, path,

modification date, etc.

Rules can be applied to specific favorites or

globally.

Use this to exclude .git  folders,

temporary files, etc.

Page 2 of 4 https://cheatsheetshero.com

https://cheatsheetshero.com/


Droplets

What is a Droplet?

A small application icon you place on your

desktop or dock. Drag files or folders onto it, and

Transmit will automatically upload them to a

predefined remote path using a specific server

favorite. Great for frequently uploading to the

same location.

How to Create a Droplet:

1. Connect to the server and navigate to the

desired remote directory.

2. Go to File > Save as Droplet… (or press Cmd 

+ Option + D ).

3. Choose a name and location for the Droplet

file (e.g., your Desktop).

4. Select the Server Favorite and the Remote

Path.

5. Optionally, configure post-transfer actions

(e.g., copy URL).

6. Click Save .

How to Use a Droplet:

1. Locate the .transmit  file (the Droplet

icon).

2. Drag the files or folders you want to upload

onto the Droplet icon.

3. Transmit will open (or come to the

foreground), connect to the server, and

upload the items to the specified remote

path.

4. A transfer window will show progress.

Editing a Droplet:

Droplets are saved .transmit  files.

Right-click the Droplet file > Get Info ( Cmd + 

I ).

You can change the name and icon like any

other macOS file.

To change server details or path, you must

recreate the Droplet.

Troubleshooting Droplets:

Ensure the Server Favorite used by the

Droplet is still valid and has the correct

credentials.

Check that the remote path specified in the

Droplet still exists on the server.

Firewall issues might prevent the connection.

Transmit must be installed and accessible.

Advanced Droplet Options:

When creating a Droplet, you can set options like:

Overwrite files if they exist

Resume broken transfers

Set permissions after upload

Copy URL after upload  (especially useful

for web servers)

Alternative Droplet Location:

Instead of the Desktop, you can place Droplets in

your Dock or a folder in your home directory

( ~/Applications  or ~/Desktop ).

Panic Sync

What is Panic Sync?

A free, secure service provided by Panic to

synchronize your Transmit favorites (server

connections) and other Panic app data across

multiple Macs.

Keeps all your server connection details up-

to-date on all your computers.

Encrypted end-to-end, Panic cannot read

your data.

Requires a free Panic Sync account.

How to Set up Panic Sync:

1. Go to Transmit > Preferences > Panic Sync.

2. Click Sign In or Create Account .

3. Follow the prompts to create a new account

or log in.

4. Choose which data to sync (Transmit

favorites, history, etc.).

5. Repeat on other Macs you want to sync with

the same account.

Managing Sync:

Go to Transmit > Preferences > Panic Sync.

See sync status (Last Synced, etc.).

Manually trigger a sync.

View devices connected to your account.

Sign out of Panic Sync.

Benefits:

Effortlessly keep server lists identical across

machines.

Backup of your server favorites.

Simplifies setup on new computers.

Important Notes:

Syncing only includes server favorites, not

passwords if stored in macOS Keychain

(which is recommended).

Sync is automatic in the background but can

be manually triggered.

Requires an internet connection for syncing.

Protocols Supported

FTP File Transfer Protocol

(standard, often insecure)

SFTP SSH File Transfer Protocol

(secure, uses SSH)

WebDAV Web Distributed Authoring

and Versioning (extension of

HTTP)

WebDAV HTTPS Secure WebDAV

S3 Amazon Simple Storage

Service

Backblaze B2 Backblaze Cloud Storage

Google Drive Google’s cloud storage

Microsoft Azure

Blob Storage

Microsoft’s cloud object

storage

Rackspace Cloud

Files

Rackspace’s cloud object

storage
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Tips and Tricks

Streamlining Workflow

Use Drag and Drop: The most intuitive way to

transfer. Drag from one pane to the other, or drag

files from Finder onto a Transmit window or

Droplet.

Save Passwords in Keychain: For security and

convenience, let macOS Keychain remember your

server passwords. Transmit integrates seamlessly

with it.

Configure Default Local Folder: In Preferences >

General, set your ‘Default Local Folder’ to a

frequently used directory to save navigation time

upon launch.

Batch Renaming: Select multiple files/folders,

right-click > Rename Items. Transmit offers

powerful batch renaming options (Add text,

Replace text, Number sequence, etc.).

Quickly Change Permissions: Select an item,

press Cmd + I  (Get Info). The permissions pane

allows graphical editing of owner, group, and

world read/write/execute permissions.

Set Default Permissions: In Server Favorites

settings, you can define default permissions to be

applied to files and folders upon upload.

Use Terminal Integration: Right-click in a pane >

Services > New Terminal at Folder. Quickly open a

Terminal window pointed at the current local or

remote directory (for SFTP/SSH connections).

Preview Files with Quick Look: Select a file and

press Spacebar  to quickly preview its content

without downloading or opening an external

editor.

Copy HTTP/S URL: For files uploaded to a web

server, right-click the file > Copy URL >

HTTP/HTTPS URL. Requires the server favorite to

have a ‘Web Server URL’ configured.

Customizing Transmit

Toolbar Customization: Right-click the toolbar >

Customize Toolbar… Drag and drop icons to add,

remove, or rearrange buttons for features you use

most often.

Preferences Settings: Explore Transmit >

Preferences ( Cmd + , ).

General: Default folders, quitting behavior.

Transfers: Rules for existing files, transfer

speed limits, number of connections.

Rules: Define file/folder rules for transfers,

syncing, and editing.

Editor: Choose your external editor and

upload/download behavior.

Advanced: Enable/disable features like

bonjour, file locking, etc.

Panic Sync: Manage account and sync

settings.

External Editor Integration: Set up your preferred

code editor or text editor in Preferences > Editor.

You can configure Transmit to upload files

automatically when saved in the external editor.

File & Folder Rules: In Preferences > Rules, create

rules to automatically perform actions based on

file type or name, like opening .txt  files in a

specific editor or excluding .DS_Store  files

from uploads.

Appearance: Transmit follows macOS

appearance settings (Light/Dark Mode).

Column View Customization: In List or Column

view, right-click the header row to choose which

columns are displayed (Size, Date Modified,

Permissions, Owner, Group, etc.). Drag headers to

reorder columns.

Custom Default Server: Set a specific server

favorite to connect to automatically when

Transmit launches in Preferences > General.

Custom Ports: When adding a server favorite, you

can specify a non-standard port for the

connection if required by the server.

Useful Hidden Features

File Locking (SFTP only): Transmit can detect if

another user is editing a file via SFTP and prevent

simultaneous edits to avoid conflicts. Enable in

Preferences > Advanced.

Local to Local Transfers: Transmit isn’t just for

remote servers! You can open two local panes

( Cmd + Option + L  to focus local, then

connect to This Mac  favorite) and use Transmit

to move/copy files between local folders using its

interface and rules.

Bonjour Support: If servers on your local network

are broadcasting via Bonjour, they may appear

automatically under ‘Nearby’ in the sidebar.

Inspector Window: Select an item and press Cmd 

+ I  to open the Inspector (Get Info) window.

Provides detailed information, permissions, dates,

and ability to change them remotely (if protocol

supports).

Create Web Location URL: Right-click a file on a

web server > Copy URL > Web Location URL. This

copies a transmit://  URL that, when opened,

will connect to that specific server and show that

file in Transmit.

Service Menu Integration: Right-click files in

Finder to send them to Transmit (if enabled in

macOS System Settings > Keyboard > Keyboard

Shortcuts > Services).

Context Menu Options: Right-click files or folders

in either pane to reveal a wealth of options like

Rename, Duplicate, Delete, Get Info, Copy Path,

Open, Edit, etc.

Advanced Filtering: Use the search bar ( Cmd + 

F ) in a directory. Click the magnifying glass icon

to reveal filter options (Kind, Date, Size, etc.)

beyond just filename matching.

History: The History sidebar ( Cmd + 2 ) shows

recent connections and accessed folders,

allowing quick return trips.
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